Legacy Plugin

Version 1.5 of Joomla! changed the way that third-party Extensions work with the Joomla! core programs. Extensions written for version 1.0 need to be modified in order to use the new 1.5 methodology. To allow for backward compatibility with existing 1.0 Extensions, a Plugin called "System - Legacy" is included with Joomla! 1.5. This Plugin allows many Extensions developed for version 1.0 to work with version 1.5. This Plugin is disabled by default and must be enabled before you can use any Extensions in "Legacy" mode. It can be enabled from the Plugin Manager screen.

Extensions that have been tested by the Extension provider to work using the Legacy Plugin are labeled as "1.5 Legacy". Extensions that use the new 1.5 methodology are labeled as "1.5 Native". In general, "1.5 Native" Extensions will perform somewhat faster than "1.5 Legacy", because the Legacy Plugin requires one extra layer of processing. Over time, it is expected that the majority of Extensions will be available in "1.5 Native" mode.

Need Help?

If you are in need of help or have any questions regarding our products you may use one of the links below:

Our Newsletter

Get the latest news, product updates and special offers!