Gantry5 templates?

Ultimate bridge for connecting Joomla! and phpBB 3.
Forum rules
This forum is not for any support questions/issues/features. Please use Support Center for such requests.
baartmns
Posts: 2
Joined: March 19th, 2018, 6:12 pm
Name: baartmns

Gantry5 templates?

Post by baartmns »

Hi,

I am thinking of purchasing p8pbb bridge for a site running on a Gantry5 template and a forum running on 3.2.2.

Now, in the Requirements I read 'phpBB 3.1+ doesn't work with Gantry5 Joomla templates.". Is this still the case? If so, what does it mean? Eg. integration of the form into the joomla part will be a no go I assume, but syncing phpbb and joomla users would still be possible I guess. Please advice.



Best, Ruud
User avatar
Admin
Site Admin
Site Admin
Posts: 970
Joined: October 21st, 2008, 5:39 pm
Name: Administrator
Browser: Chrome

Re: Gantry5 templates?

Post by Admin »

Actually, I've just tested newest Gantry5 and Helium template, it works fine and the old bad code is improved.

So, Gantry5 should not be a problem anymore.
baartmns
Posts: 2
Joined: March 19th, 2018, 6:12 pm
Name: baartmns

Re: Gantry5 templates?

Post by baartmns »

Great!
Exiga
Posts: 2
Joined: May 8th, 2018, 9:50 am
Name: Lieven Dewitte

Re: Gantry5 templates?

Post by Exiga »

I've recently purchased the bridge module and tested in on a standard Joomla install and that worked fine. But I also used it on a website with a template based on the Gantry framework (v5.4.34 now) and this completely messes up the Joomla user management (login, logout features) as well as the autologin/autologout functions in the bridge too. So is your statement from above still valid or is there an issue that I'm not aware off?
User avatar
Admin
Site Admin
Site Admin
Posts: 970
Joined: October 21st, 2008, 5:39 pm
Name: Administrator
Browser: Chrome

Re: Gantry5 templates?

Post by Admin »

We have just tested Helium theme v. 5.4.35 and found out that it won't due to conflicts between Twig versions in Gantry and phpBB.

Unfortunately, Gantry uses outdated Twig version.
Exiga
Posts: 2
Joined: May 8th, 2018, 9:50 am
Name: Lieven Dewitte

Re: Gantry5 templates?

Post by Exiga »

Thanks for the clarification. So we'll have this issue as long as Gantry hasn't got twig v2 on board (which phpBB uses). We're looking into a manual fix, but this still is a serious setback.

Greets,