phpBB 3.1 released

Discuss and comment our news here.
User avatar
Admin
Site Admin
Site Admin
Posts: 1586
Joined: October 21st, 2008, 5:39 pm
Name: Administrator
Browser: Chrome

phpBB 3.1 released

Post by Admin » October 28th, 2014, 9:20 pm

Finally the new phpBB 3.1 Ascraeus is released, we are performing final tests and will also release updated p8pbb bridge versions (full and light editions) this week.

New jprosilver 3.1 theme specially adopted for wrapped mode will be also available.

For now we don't recommend to upgrade to phpBB 3.1 because bugs happen :), better wait a week.
Read full article...

MrAnonymous
Rookie
Rookie
Posts: 44
Joined: May 13th, 2014, 3:44 pm
Name: Neel

Re: phpBB 3.1 released

Post by MrAnonymous » November 3rd, 2014, 2:55 am

I see you have updated the forum here to 3.1. Good to see... Have you decided when 3.1 bridge will be out? Is it possible in the next couple of days or could it take longer? :)

User avatar
Admin
Site Admin
Site Admin
Posts: 1586
Joined: October 21st, 2008, 5:39 pm
Name: Administrator
Browser: Chrome

Re: phpBB 3.1 released

Post by Admin » November 3rd, 2014, 1:37 pm

Should be definitely till Friday, we want to test it on our live forum a bit.

MrAnonymous
Rookie
Rookie
Posts: 44
Joined: May 13th, 2014, 3:44 pm
Name: Neel

Re: phpBB 3.1 released

Post by MrAnonymous » November 3rd, 2014, 4:33 pm

Thank you. I am working on it as well atm. Having a pain dealing with the jquery conflicts when Joomla uses mootools. Other than that, rest seems fine.

MrAnonymous
Rookie
Rookie
Posts: 44
Joined: May 13th, 2014, 3:44 pm
Name: Neel

Re: phpBB 3.1 released

Post by MrAnonymous » November 3rd, 2014, 4:38 pm

How did you get the plupload to work? You didint have any conflict with Joomla? Does Jprosilver has any updated forum_fn.js or not really since the conflicts are usually related to the templates?

MrAnonymous
Rookie
Rookie
Posts: 44
Joined: May 13th, 2014, 3:44 pm
Name: Neel

Re: phpBB 3.1 released

Post by MrAnonymous » November 4th, 2014, 12:39 pm

MrAnonymous wrote:How did you get the plupload to work? You didint have any conflict with Joomla? Does Jprosilver has any updated forum_fn.js or not really since the conflicts are usually related to the templates?
Never mind the last post. It was actually the 'extract script' that was causing me the issue. Sorry, didnt mean to go off-topic on the announcement topic here. :) My apologies...

User avatar
Admin
Site Admin
Site Admin
Posts: 1586
Joined: October 21st, 2008, 5:39 pm
Name: Administrator
Browser: Chrome

Re: phpBB 3.1 released

Post by Admin » November 4th, 2014, 4:08 pm

It's a right place!

We have just fixed plupload, it works here.

For now jprosilver doesn't have own .js files, we try to make it as more dependent on original prosilver as possible. I.e. for now it has 4 own template files only.

MrAnonymous
Rookie
Rookie
Posts: 44
Joined: May 13th, 2014, 3:44 pm
Name: Neel

Re: phpBB 3.1 released

Post by MrAnonymous » November 4th, 2014, 4:45 pm

Perfect.. Thanks for that admin.

With the plupload, you are right.. I can see its fixed here now. I was noticing the "Error parsing server response" error before and now its not there. Awesome.. I see you really are busy with the final testings :)

With the plupload, how did you fix it? Since jprosilver doesnt have a modified js file, was the fix something that was added with the bridge itself?

The only other thing I noticed here is, I dont see the pop-up confirmation dialog when you click on the subscribe topic in the action bar at the top. The ajax subscribe works but just the pop-up message doesnt show. I noticed the same thing in my test site I've got in my wamp localhost too..

User avatar
Admin
Site Admin
Site Admin
Posts: 1586
Joined: October 21st, 2008, 5:39 pm
Name: Administrator
Browser: Chrome

Re: phpBB 3.1 released

Post by Admin » November 5th, 2014, 1:04 pm

We added single line of code into plupload.html template.

Thanks for noticing subscribe/unsubscribe popup, should be fixed soon.

MrAnonymous
Rookie
Rookie
Posts: 44
Joined: May 13th, 2014, 3:44 pm
Name: Neel

Re: phpBB 3.1 released

Post by MrAnonymous » November 5th, 2014, 2:50 pm

Brilliant. Thank you so much Admin for sharing how you fixed the plupload. When you do get a chance to fix the subscribe/unsubscribe popup, please do let me know how you fixed it too. I am curious to know since it is not showing any error in the console and ajax seems to work fine. :)

Again, you are doing an amazing job.